Back to overview
Degraded

Power outage affecting all services

May 25, 2026 at 4:58pm UTC
Affected services
us-grrapids
Primary Website
Object Storage
Knowledge Base
Authentication Service
Web Console
Domains

Resolved
May 25, 2026 at 5:36pm UTC

We have identified the root cause of the problem and it has been resolved. Thanks for your patience!

Created
May 25, 2026 at 4:58pm UTC

We’re working to fix the problem as quickly as we can. We’ll share another update shortly.